Как обойти все элементы формы

Как перебрать все свойства объекта формы

 

Для обращения ко всем элементам формы у формы есть свойство которое так и называется "ЭлементыФормы", обращаться к нему можно из модуля формы.

Для Каждого ТекЭлемент из ЭлементыФормы Цикл
	// ТекЭлемент.Имя
	// ТипЗнч(ТекЭлемент) - выводит тип элемента
	// Строка(ТекЭлемент) - выводит тип элемента строкой, например "ПолеВвода"
	// ТекЭлемент.Видимость
	// ТекЭлемент.Доступность
	// и т.д.
КонецЦикла;

Также к этому свойству можно обратиться через полученную форму:

СпрСсылка = Справочники.Номенклатура.НайтиПоНаименованию("Табурет");
СпрФорма = СпрСсылка.ПолучитьФорму();
СпрЭлементыФормы = СпрФорма.ЭлементыФормы;

Как перебрать все свойства объекта формы

Кроме этого можно и наоборот из формы обратиться к свойствам объекта, его реквизитам и табличным частям:


Для Каждого ТекРеквизит из Метаданные().Реквизиты Цикл
		// ТекРеквизит.Имя
КонецЦикла;

Для Каждого ТекТабЧасть из Метаданные().ТабличныеЧасти Цикл
		// ТекТабЧасть.Имя
КонецЦикла;

Но, здесь в этом случае мы узнаем только какие свойства есть, а не их значения. Чтобы узнать значения нужен конкретный объект.

Добавить комментарий

>>> Комментарии от незарегистрированных пользователей будут опубликованы после ПРОВЕРКИ модератора. <<<


Защитный код
Обновить